Machswap : une nouvelle vulnérabilité pour le jailbreak iOS 11 à iOS 12.1.2 avec prise en charge des appareils A10-A11 et peut-être A12

vulnerabilite machswap jailbreak ios 12

Le célèbre hacker PsychoTea a publié vendredi une première vulnérabilité appelé machswap pour les appareils A7 à A9 sous iOS 11.0 à iOS 12.1.2 et a réussi à poter son exploit machswap pour la prise en charge des appareils A10 et A11. Cela signifie que l’exploit machswap est maintenant viable pour la plupart des appareils qui fonctionnent sous iOS 12 mais ce n’est pas tout.

Seule les appareils iOS équipés du processeur A12 variété ne serait pas supportés par la vulnérabilité machswap actuellement. Les appareils A12 englobent la toute dernière gamme d’appareils d’Apple comprenant les iPhone XS, XS Max et XR.

Cependant, le manque de support pour les appareils A12 n’est pas dû à une incompatibilité mais au fait que le hacker ne possède pas ce type d’appareil pour tester et construire l’exploit. Cela signifie que la prise en charge des iPhone et iPad de dernière génération pourraient potentiellement être possible si quelqu’un est capable de mettre à jour cette vulnérabilité.

exploit machswap jailbreak ios 12

En plus de la prise en charge plus large des appareils, le hacker indique quelques détails sur l’exploit lui-même, comme le fait qu’il ne prend que deux à quatre secondes pour être réaliser.

Si vous avez déjà utilisé le jailbreak unc0ver ou Electra, vous vous êtes probablement rendu compte qu’effectuer le jailbreak prend un certain temps et que le taux de succès n’est pas élevé (il faut s’y reprendre plusieurs fois). Mais la nouvelle vulnérabilité de PsychoTea semble régler ces deux problèmes. Pour cette raison, il faut s’attendre à ce que les outils de jailbreak utilisent l’exploit machswap dans leurs futures mises à jour au profit de la communauté.

Source

veritas certification verification equipement electronique mondial

Rédiger un Commentaire

avatar