Semaphorin, l’outil de jailbreak et downgrade basé sur checkm8, prend en charge les appareils A10X et A11, et plus encore…

Le projet connu sous le nom de Semaphorin est un utilitaire de downgrade et de jailbreak pour certains appareils vulnérables à l’exploitation du bootrom checkm8 fonctionnant avec différentes versions d’iOS, jouant ainsi un rôle important au sein de la communauté.

Dans un message partagé sur le forum communautaire Reddit, les développeurs ont admis que la version initiale avait été un “flop” en raison de “bugs incessants” et qu’ils avaient travaillé dur pour améliorer la réputation de l’outil et son utilité pour la communauté. La version 1.0 est désormais officiellement disponible sur la page GitHub du projet, ce qui indique que la version bêta initiale est désormais une chose du passé. Les changements les plus notables de la dernière version sont les suivants :

Vous pouvez désormais rétrograder votre iPhone même sous iOS 16 ou une version ultérieure avant le downgrade.

  • Semaphorin prend désormais en charge les appareils A10X et A11 en plus des appareils A7-A10.
  • Les problèmes liés aux applications Appareil photo et Photos sont désormais résolus
  • Les problèmes liés à l’USB sont maintenant corrigés, en particulier sur les appareils A7 où le problème était le plus important.
  • Prise en charge d’iOS 9, même pour les appareils A9, y compris l’iPhone 6s et l’iPhone SE
  • Prise en charge d’iOS 8 pour les appareils A8, y compris l’iPhone 6
  • Et bien plus encore…

Avec ces derniers changements, Semaphorin est désormais utilisable par toute personne utilisant un appareil A7-A11 sur presque toutes les versions d’iOS, et il vous permet de downgrader vers des versions allant d’iOS 7.0.6 à 12.1 de manière tethered sans avoir besoin de blobs SHSH, ce qui est une prouesse particulièrement étonnante.

Évidemment, comme l’outil ne fonctionne que sur les appareils vulnérables à l’exploit checkm8 bootrom, il n’y a aucune chance qu’il fonctionne un jour avec un appareil plus récent que l’iPhone X. Mais la bonne nouvelle, c’est que l’iPhone X est entièrement pris en charge !

Les développeurs avertissent que même si Semaphorin inclut une version GUI, il n’est pas conseillé de l’utiliser. Il est préférable d’utiliser la version CLI, c’est-à-dire d’exécuter des commandes dans Terminal plutôt que de cliquer sur des boutons. Un bref résumé de son utilisation est fourni dans le post /r/jailbreak dont voici un condensé.

Comment utiliser Semaphorin ?

Ce script supprime tout ce qui se trouve sur votre téléphone, y compris le système d’exploitation principal si vous ne passez pas à iOS 10.3.3 ou à une version ultérieure. Assurez-vous de sauvegarder toutes vos données avant d’utiliser ce script car tout ce qui se trouve sur l’appareil avant l’exécution de ce script sera irrécupérable par la suite. Utilisez ce script à vos risques et périls. Nous ne sommes pas responsables des dommages causés par l’utilisation de ce script.

Pour utiliser cette application, vous devez passer à une version supportée, et avoir un appareil supporté.

Shell

Connecter l’appareil en mode DFU

Shell

Par exemple, vous pouvez écrire `sudo ./semaphorin.sh 9.5 -restore`

Le script doit sauvegarder les fichiers importants de votre version actuelle d’iOS avant que vous ne puissiez rétrograder.

Lorsque le script demande “Veuillez entrer la version d’iOS qui est actuellement installée sur votre appareil“, tapez votre version d’iOS actuelle et appuyez sur la touche Entrée pour continuer.

Le processus de rétrogradation de votre appareil devrait alors commencer. Veuillez suivre les instructions à l’écran. Cela peut prendre un certain temps. Votre appareil va redémarrer plusieurs fois.

Exécutions suivantes après la fin de la rétrogradation

Connecter l’appareil en mode DFU

Shell

Par exemple, si vous avez rétrogradé vers iOS 9.3, vous pouvez lancer `sudo ./semaphorin.sh 9.5 -boot`.

Il devrait démarrer normalement avec la version d’iOS que vous avez demandée.

Ceux qui souhaitent en savoir plus sur Semaphorin peuvent se rendre sur la page GitHub du projet, où vous trouverez des détails supplémentaires. Si vous avez un appareil plus récent équipé d’une puce A12 ou plus récente, vous pouvez continuer la lecture car cet outil n’est pas pour vous.

S'abonner
Notification pour
guest
0 Commentaires
Evaluation en ligne
Voir tous les commentaires